summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKillswitch2020-08-15 22:51:32 +0200
committerKillswitch2020-08-15 22:51:32 +0200
commitccfcdf6ff67d38c73a1d7dbbd03bf4e1cf8faea8 (patch)
tree009981800f6a6f0ef2bf9fd1c2833023d0a6ba2a /PKGBUILD
parentb2691dc545e52d149164b780bc033b187ad077b0 (diff)
downloadaur-ccfcdf6ff67d38c73a1d7dbbd03bf4e1cf8faea8.tar.gz
Implemented revisioning as well
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59227cb958db..144cf22b6744 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=powercord-git
_pkgname=powercord
pkgver=r1178.41cb7ce
-pkgrel=4
+pkgrel=5
pkgdesc="A lightweight discord client mod focused on simplicity and performance."
arch=("any")
url="https://github.com/powercord-org/$_pkgname"
@@ -38,6 +38,10 @@ prepare() {
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-settings/index.js -i ${srcdir}/pc-settings_index.js.patch
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-updater/index.js -i ${srcdir}/pc-updater_index.js.patch
patch -u ${srcdir}/${_pkgname}/src/Powercord/plugins/pc-updater/components/Settings.jsx -i ${srcdir}/pc-updater_settings.jsx.patch
+
+ cd "${srcdir}/${_pkgname}"
+ local _revision="$(git rev-list HEAD | head -n 1)"
+ sed -i "s/REVISION_NUMBER/${_revision}/" "${srcdir}/${_pkgname}/src/Powercord/index.js"
}
pkgver() {