summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSergey Shatunov2016-11-04 19:15:03 +0700
committerSergey Shatunov2016-11-04 19:15:03 +0700
commit039dca2bacf697828616baa0f5bf642e47c01400 (patch)
treecf5d35831221e41cd29a93d753b8fd25999f1493 /PKGBUILD
parent12700392519bda0c590bd409db97efb87509d33c (diff)
downloadaur-039dca2bacf697828616baa0f5bf642e47c01400.tar.gz
Install common sql modules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8af909debace..2a07b269c92f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sergey Shatunov <me@prok.pw>
pkgname=powerdns-admin-git
pkgver=r220.e18757e
-pkgrel=2
+pkgrel=3
pkgdesc="Web GUI for PowerDNS autoritative server"
arch=('any')
url="https://github.com/ngoduykhanh/PowerDNS-Admin"
@@ -9,7 +9,9 @@ license=('MIT')
options=(!strip)
depends=('python2')
makedepends=('git' 'python2-pip' 'python2-virtualenv')
-optdepends=('powerdns: autoritative server itself')
+optdepends=('powerdns: autoritative server itself'
+ 'postgresql: postgresql backend'
+ 'mariadb: mysql backend')
install=powerdns-admin.install
backup=(etc/webapps/powerdns-admin/config.py)
source=('powerdns-admin-git::git+https://github.com/ngoduykhanh/PowerDNS-Admin.git'
@@ -32,7 +34,7 @@ build() {
virtualenv2 venv
virtualenv2 --relocatable venv
source venv/bin/activate
- PIP_CONFIG_FILE=/dev/null pip2 install --isolated --ignore-installed -r requirements.txt
+ PIP_CONFIG_FILE=/dev/null pip2 install --isolated --ignore-installed -r requirements.txt psycopg2 MySQL-python
}
package() {