summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfenuks2017-09-02 13:27:07 +0200
committerfenuks2017-09-02 13:27:07 +0200
commitb0f93e3b37712f6935564fee63dce63122de4ff0 (patch)
treea0fae364c1fb444bd002b6d6a289a6389e3a2741 /PKGBUILD
downloadaur-b0f93e3b37712f6935564fee63dce63122de4ff0.tar.gz
Initial release, version 1.5.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ad672d70414
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: fenuks
+
+_pkgname=powerline-go
+_binary=${_pkgname}-linux-amd64
+pkgname=${_pkgname}-bin
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="A beautiful and useful low-latency prompt for your shell, written in go"
+arch=("x86_64")
+url="https://github.com/justjanne/powerline-go"
+license=("GPL3")
+depends=()
+optdepends=("powerline-fonts: fonts with powerline symbols")
+makedepends=()
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+install=$pkgname.install
+source=("https://github.com/justjanne/${_pkgname}/releases/download/v${pkgver}/${_binary}")
+
+sha256sums=('435691c2fdfd2c047568e1a1fc2fdb7491e267888446d9592f3b30403cb3d21e')
+
+package() {
+ install -Dm755 "${srcdir}/${_binary}" "${pkgdir}/usr/bin/${_pkgname}"
+}