summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Wellnitz2018-07-15 21:06:44 +0200
committerPhilip Wellnitz2018-07-15 21:06:44 +0200
commitce0601f7c9f0aa88f24891f3b10550db43c8be4b (patch)
tree789b87e6b7131b6241dc0df17e97135876264706 /PKGBUILD
parentbff92eb53954df38b3652d1c75606f595f06ad52 (diff)
downloadaur-ce0601f7c9f0aa88f24891f3b10550db43c8be4b.tar.gz
add new opt depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cc8759f7fcb..27f3be4e8fdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=powerline-i3-git
_pkgname=powerline
-pkgver=1.7.18.1
+pkgver=1.8.0.5
pkgrel=1
pkgdesc="The ultimate statusline/prompt utility. A fork containing more features for the i3 window manager."
arch=('i686' 'x86_64')
@@ -17,13 +17,21 @@ depends=(
'python-xlib'
)
optdepends=(
- 'python-dbus: player segments using dbus'
+ 'python-dbus: player segments using dbus, global menu support'
'python-iwlib: wireless segment'
'python-pyalsaaudio: volume segment'
'python-psutil: cpu load segment'
'python-pygit2: better git performance of the vcs segment'
'python-google-api-python-client: Google Calendar support for the appoints segment'
'xorg-xinput: screen rotation segment'
+ 'appmenu-qt4: global menu support in qt4 apps'
+ 'appmenu-qt5: global menu support in qt5 apps'
+ 'appmenu-gtk-module-git: global menu support in gtk apps'
+ 'libdbusmenu-glib: global menu support for chrome/chromium'
+ 'libdbusmenu-gtk3: global menu support for chrome/chromium'
+ 'libdbusmenu-gtk2: global menu support for chrome/chromium'
+ 'pygtk: global menu support'
+ 'python-gobject: global menu support'
)
makedepends=(
'python-setuptools'
@@ -49,5 +57,5 @@ package() {
echo ">>> status_command i3status"
echo ">>> }"
echo ">>> in your i3/config with this line:"
- echo ">>> exec_always \"killall powerline-lemonbar; powerline-lemonbar --i3 --height 16 -- -a 40 -b -f 'DejaVu Sans Mono-11' -f 'PowerlineSymbols-12' -f 'FontAwesome-11'\""
+ echo ">>> exec_always \"killall powerline-lemonbar; powerline-lemonbar\""
}