summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Schmidt2018-02-04 21:24:11 +0100
committerStefan Schmidt2018-02-04 21:24:11 +0100
commit388808557479ac6301d75782baff31926e52ec00 (patch)
tree3da3aa4e5efc1976bc22552ca7e36ea44010148f /PKGBUILD
parent46676a654827dce2088a5c7a08a3207a04f1d642 (diff)
downloadaur-388808557479ac6301d75782baff31926e52ec00.tar.gz
Fixed gcc compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 940b792c9200..25ee9e0cac75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ pkgname=${_target}-gcc-stage1
pkgver=6.1.1
_pkgver=6
_islver=0.16.1
-pkgrel=3
+pkgrel=4
_commit=1bbd3999
pkgdesc="The GNU Compiler Collection. Stage 1 for toolchain building (${_target})"
arch=('i686' 'x86_64')
@@ -20,12 +20,16 @@ depends=("${_target}-binutils>=2.26.1-1" 'libmpc' 'zlib')
options=('!emptydirs' '!distcc' '!strip')
source=(https://github.com/gcc-mirror/gcc/archive/${_commit}.tar.gz
http://isl.gforge.inria.fr/isl-${_islver}.tar.bz2)
-md5sums=('d4c4546f927b2984d66574b1b5cb817e'
+md5sums=('ff2d7ad9a3144299decbdad85dfcb920'
'ac1f25a0677912952718a51f5bc20f32')
prepare() {
mv gcc-${_commit}* gcc
- cd ${srcdir}/gcc
+ cd ${srcdir}
+
+ patch -Np0 < "../fix-compilation.patch"
+
+ cd gcc
# link isl for in-tree build
ln -s ../isl-${_islver} isl