summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle Sferrazza2019-04-24 14:35:40 -0400
committerKyle Sferrazza2019-04-24 14:35:40 -0400
commit831115742d8c71a6cfeb10185a7969b26a00e60d (patch)
tree0ae366ce34b201257566715ce12802cc9cf33655 /PKGBUILD
parent40e150589fc5a7a27e6cba6c872d9a6b19e18513 (diff)
downloadaur-831115742d8c71a6cfeb10185a7969b26a00e60d.tar.gz
remove googletest
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37d56b171ef5..ae5795b03bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,13 +12,11 @@ url='https://github.com/PowerShell/PowerShell'
license=('MIT')
makedepends=('git' 'cmake' 'dotnet-sdk>=2.0')
depends=('icu' 'openssl-1.0')
-source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
- powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git
- googletest::git+https://github.com/google/googletest.git
- "Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets")
+source=($pkgname::"git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver"
+ 'powershell-native::git+https://github.com/PowerShell/PowerShell-Native.git'
+ 'Microsoft.PowerShell.SDK.csproj.TypeCatalog.targets')
md5sums=('SKIP'
'SKIP'
- 'SKIP'
'56f02557575a6022b60be609951eee78')
install=powershell.install
@@ -86,14 +84,14 @@ package() {
chmod 755 "$pkgdir/usr/lib/$pkgname/linux-x64/$binaryname"
mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
- cp ../../LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cp "../../LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
mkdir -p "$pkgdir/usr/bin"
ln -s "/usr/lib/$pkgname/linux-x64/$binaryname" "$pkgdir/usr/bin/$binaryname"
chmod 644 \
- $pkgdir/usr/lib/powershell/linux-x64/libhostfxr.so \
- $pkgdir/usr/lib/powershell/linux-x64/libhostpolicy.so \
- $pkgdir/usr/lib/powershell/linux-x64/en-US/default.help.txt \
- $pkgdir/usr/lib/powershell/linux-x64/Modules/PSDesiredStateConfiguration/PSDesiredStateConfiguration.psm1
+ "$pkgdir/usr/lib/powershell/linux-x64/libhostfxr.so" \
+ "$pkgdir/usr/lib/powershell/linux-x64/libhostpolicy.so" \
+ "$pkgdir/usr/lib/powershell/linux-x64/en-US/default.help.txt" \
+ "$pkgdir/usr/lib/powershell/linux-x64/Modules/PSDesiredStateConfiguration/PSDesiredStateConfiguration.psm1"
}