summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHyacinthe Cartiaux2014-02-07 15:24:23 +0100
committerHyacinthe Cartiaux2015-06-09 14:09:36 +0200
commit544555ad87964b215e39d3e34915c42097036234 (patch)
treecaaafb1ceb97284f324847e286d1148bc651f7f9 /PKGBUILD
downloadaur-544555ad87964b215e39d3e34915c42097036234.tar.gz
[powerstat-git] Adopted package, initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7842f2e1ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Eugeni Dodonov <eugeni@dodonov.net>
+
+pkgname=powerstat-git
+pkgver=20120328
+pkgrel=1
+pkgdesc="a tool for measuring a laptops power usage via the battery"
+arch=(i686 x86_64)
+url="http://kernel.ubuntu.com/git?p=cking/powerstat.git"
+license=(GPL)
+depends=(glibc)
+makedepends=(make)
+
+provides=('powerstat')
+
+_gitroot=git://kernel.ubuntu.com/cking/powerstat.git
+_gitname=powerstat
+
+build() {
+ cd ${srcdir}
+ if [ -d $_gitname ] ; then
+ ( cd $_gitname && git pull )
+ else
+ git clone $_gitroot
+ fi
+
+ rm -rf "${_gitname}_build"
+ cp -r "${_gitname}" "${_gitname}_build"
+
+ cd "${_gitname}_build/"
+ make
+}
+
+package() {
+ cd "$srcdir/${_gitname}_build"
+ make DESTDIR="$pkgdir/" install
+}