summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMike Swanson2017-03-22 23:29:01 -0700
committerMike Swanson2017-03-22 23:29:01 -0700
commitcf48f6529cd6cded6776407380d09e73692be1da (patch)
tree134e840d27ea6ccbedd11feaeeff2fbdb1d21646 /PKGBUILD
parentb6d1e5ee8b53e2c94560d4aa6b3e8c257497e548 (diff)
downloadaur-cf48f6529cd6cded6776407380d09e73692be1da.tar.gz
Look, Git tags!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c57a1aaaff91..73d0f90b988c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
pkgname=pps-tools-git
-pkgver=r23.9d82bc4
+pkgver=1.0.r0.9d82bc4
pkgrel=1
pkgdesc="LinuxPPS user-space tools"
arch=('aarch64' 'arm7vh' 'i686' 'x86_64')
url="http://linuxpps.org/"
license=('GPL2')
provides=('pps-tools')
+makedepends=('git')
source=("git+https://github.com/ago/pps-tools")
sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf %s "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//g')"
}
build() {