summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2023-08-25 11:31:57 +0300
committerStelios Tsampas2023-08-25 11:31:57 +0300
commit7f706a7ed89fe686e119c972f71a18dbab90c903 (patch)
tree8396cda2c834fa3e8b43e9898d82fde31f74a81a /PKGBUILD
parent31865a4a6bd9a6c6722a324fcd64444508015c3a (diff)
downloadaur-7f706a7ed89fe686e119c972f71a18dbab90c903.tar.gz
[ppsspp-git] Add skeleton for multiarch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbb12b4fc6e0..4959ee210a39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=(
ppsspp-git
ppsspp-assets-git
)
-pkgver=1.15.4.r562.04932d98a7
+pkgver=1.15.4.r1211.308e983a99
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=(x86_64)
@@ -95,10 +95,16 @@ prepare() {
build() {
export CC=clang
export CXX=clang++
+
# Rebuild ffmpeg locally
pushd ppsspp/ffmpeg
- ./linux_x86-64.sh
+ case "$CARCH" in
+ x86_64)
+ ./linux_x86-64.sh
+ ;;
+ esac
popd
+
cmake -S ppsspp -B build-sdl -G Ninja \
-Wno-dev \
-DCMAKE_BUILD_TYPE=Release \
@@ -112,6 +118,7 @@ build() {
-DUSE_SYSTEM_ZSTD=ON \
-DUSING_QT_UI=OFF
cmake --build build-sdl -v
+
cmake -S ppsspp -B build-qt -G Ninja \
-Wno-dev \
-DCMAKE_BUILD_TYPE=Release \