summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2023-06-30 13:03:47 +0300
committerStelios Tsampas2023-06-30 13:03:47 +0300
commitb61ad95edd3b672743faa4c68ff72801378800b3 (patch)
tree411c63e5095cc243f9d12b31e9a80c555e2ecfa5 /PKGBUILD
parenta62644829bbbc3a3d7dbdd86d9b77ead973a70c0 (diff)
downloadaur-b61ad95edd3b672743faa4c68ff72801378800b3.tar.gz
[ppsspp-git] Add rcheevos module
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a83500640846..2f616abbfee4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=(
ppsspp-git
ppsspp-assets-git
)
-pkgver=1.14.4.r1397.baa066c7b7
+pkgver=1.15.4.r357.42d4b5d41d
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=(x86_64)
@@ -42,12 +42,13 @@ source=(
git+https://github.com/discordapp/discord-rpc.git
git+https://github.com/hrydgard/ppsspp-ffmpeg.git
armips-filesystem::git+https://github.com/Kingcom/filesystem.git
+ git+https://github.com/google/cpu_features.git
git+https://github.com/KhronosGroup/glslang.git
git+https://github.com/hrydgard/ppsspp-lang.git
ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
git+https://github.com/Tencent/rapidjson.git
git+https://github.com/KhronosGroup/SPIRV-Cross.git
- git+https://github.com/google/cpu_features.git
+ git+https://github.com/RetroAchievements/rcheevos.git
ppsspp-sdl.desktop
ppsspp-qt.desktop
)
@@ -62,6 +63,7 @@ b2sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468'
'328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0')
@@ -77,7 +79,7 @@ prepare() {
git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
git -c protocol.file.allow=always submodule update ${submodule}
done
- for submodule in ext/{armips,discord-rpc,rapidjson,SPIRV-Cross,cpu_features,glslang}; do
+ for submodule in ext/{armips,cpu_features,discord-rpc,glslang,rapidjson,SPIRV-Cross,rcheevos}; do
git submodule init ${submodule}
git config submodule.${submodule}.url ../${submodule#*/}
git -c protocol.file.allow=always submodule update ${submodule}