summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-04-02 20:09:33 +0300
committerCaleb Maclennan2020-04-02 20:09:33 +0300
commit738122b2766d3235001fcc9510f52495361616a2 (patch)
treeb1e61adb0ca833f2e81a131c201f3461fa69650d /PKGBUILD
parente81e350671e16d2997da6a52745721e8b9f69273 (diff)
downloadaur-738122b2766d3235001fcc9510f52495361616a2.tar.gz
Build will all backends, promote optdepends (that have to be present at build time) to depends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 13 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dacfb30e74b6..258199cc094c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,24 @@
pkgname=pqiv
pkgver=2.11
-pkgrel=1
-pkgdesc="Modern rewrite of Quick Image Viewer"
-arch=('i686' 'x86_64')
-url="https://github.com/phillipberndt/$pkgname/"
+pkgrel=2
+pkgdesc='Modern rewrite of Quick Image Viewer'
+arch=('x86_64' 'i686')
+url="https://github.com/phillipberndt/$pkgname"
license=('GPL3')
-depends=('gtk3' 'libarchive>=3.3.2')
-optdepends=('libspectre: PS/EPS support'
- 'poppler: PDF support'
- 'libwebp: WebP support'
- 'imagemagick: additional image formats like PSD'
-)
-source=("https://github.com/phillipberndt/$pkgname/archive/$pkgver.tar.gz")
+depends=('ffmpeg'
+ 'gtk3'
+ 'imagemagick'
+ 'libarchive'
+ 'libspectre'
+ 'libwebp'
+ 'poppler-glib')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('ea1f8b6bcb58dee19e2d8168ef4efd01e222c653eabbd3109aad57a870cc8c9b')
build() {
cd "$pkgname-$pkgver"
- ./configure --backends=archive,gdkpixbuf
+ ./configure
make
}