summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-16 16:24:50 +0300
committerCaleb Maclennan2021-08-16 16:24:50 +0300
commitcfdd352c40ba02190866a11b9bb451f091d3a7ae (patch)
treeb580c464147cdb39adbd1a3934ed32e66ba8ec15 /PKGBUILD
parent5975cd0025b1db8ef9309b09902c0643c30e5141 (diff)
downloadaur-cfdd352c40ba02190866a11b9bb451f091d3a7ae.tar.gz
upgpkg: praat 6.1.51-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 20 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bcbed19094e3..aa76f834ba55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,12 +10,17 @@
pkgname=praat
pkgver=6.1.51
-pkgrel=1
+pkgrel=2
pkgdesc='A speech analysis tool used for doing phonetics by computer'
-arch=('x86_64' 'i686')
-url='https://www.praat.org'
-license=('GPL')
-depends=('alsa-lib' 'gtk3' 'jack' 'libpulse' 'ttf-charis-sil' 'ttf-sil-doulos')
+arch=(x86_64 i686 aarch64)
+url=https://www.praat.org
+license=(GPL)
+depends=(alsa-lib
+ gtk3
+ jack
+ libpulse
+ ttf-charis-sil
+ ttf-sil-doulos)
optdepends=('ttf-sil-fonts')
_url="https://github.com/$pkgname/$pkgname"
source=("$pkgname-$pkgver.tar.gz::$_url/archive/v$pkgver.tar.gz"
@@ -30,20 +35,20 @@ sha256sums=('f39b7f1dc4ab01f6cd63c102573597d7c30f6961de2db0c0b5c164d9d87640b3'
'07abf61475f22f83f0514a8fba1ec7bd3821d2b7f35b1215c1f3e1feb947d74b')
prepare() {
- cd "$pkgname-$pkgver"
- cp makefiles/makefile.defs.linux.pulse makefile.defs
+ cd "$pkgname-$pkgver"
+ cp makefiles/makefile.defs.linux.pulse makefile.defs
}
build() {
- cd "$pkgname-$pkgver"
- make
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 -t "$pkgdir/usr/bin" "$pkgname"
- install -Dm644 -t "$pkgdir/usr/share/applications/" "../$pkgname.desktop"
- install -Dm644 -t "$pkgdir/usr/share/icons/hicolor/scalable/apps/" "../$pkgname.svg"
- install -Dm644 -t "$pkgdir/usr/share/pixmaps/" "../$pkgname.xpm"
- install -Dm644 -t "$pkgdir/usr/share/man/man1/" "../$pkgname.1"
+ cd "$pkgname-$pkgver"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "../$pkgname.desktop"
+ install -Dm0644 -t "$pkgdir/usr/share/icons/hicolor/scalable/apps/" "../$pkgname.svg"
+ install -Dm0644 -t "$pkgdir/usr/share/pixmaps/" "../$pkgname.xpm"
+ install -Dm0644 -t "$pkgdir/usr/share/man/man1/" "../$pkgname.1"
}