summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilliam Turner2017-01-31 11:31:23 -0500
committerWilliam Turner2017-01-31 11:31:23 -0500
commit18f793badcd028b0456099472491d7cd7d31bb4c (patch)
tree0541c2ee58813f4ea4036dcb29a90f37583c84db /PKGBUILD
downloadaur-18f793badcd028b0456099472491d7cd7d31bb4c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b06210b6d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgname=presto-cli
+pkgver=0.164
+pkgrel=1
+pkgdesc='Distributed SQL Query Engine for Big Data - Client'
+arch=('any')
+url='https://prestodb.io/'
+license=('custom:Apache 2')
+depends=('java-runtime>=8' 'sh')
+source=("https://repo1.maven.org/maven2/com/facebook/presto/presto-cli/${pkgver}/presto-cli-${pkgver}-executable.jar"
+ 'https://raw.githubusercontent.com/prestodb/presto/master/LICENSE')
+noextract=("presto-cli-${pkgver}-executable.jar")
+sha256sums=('65fb413d9ba970d97450afc81abfb76a229124f564bc69ea00faa7dbd54792ac'
+ 'cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30')
+
+package() {
+ cd "${srcdir}"
+
+ # install in bin
+ install -D -m755 "presto-cli-${pkgver}-executable.jar" "${pkgdir}/usr/bin/presto"
+
+ # add license
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}