summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkiwiyou2021-09-09 23:18:21 +0900
committerkiwiyou2021-09-09 23:18:21 +0900
commitd61e5f8b489cb3cc1663da8a66178d4e7634188b (patch)
tree66707d8b40d03eaedf3d8bfc962c1c3ed9b567b4 /PKGBUILD
downloadaur-d61e5f8b489cb3cc1663da8a66178d4e7634188b.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3e87531fb01
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: kiwiyou <kiwiyou.dev@gmail.com>
+
+pkgbase=pretendard
+pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="A cross-platform multilingual sans-serif font mainly for Korean support"
+url="https://github.com/orioncactus/pretendard"
+arch=('any')
+license=('OFL')
+source=("https://github.com/orioncactus/pretendard/releases/download/v${pkgver}/Pretendard-${pkgver}.zip")
+sha256sums=('9a7c0df1e5c8e17836005776263fc6770ff1da5f85e7a653222a24d95daf8844')
+
+package_otf-pretendard() {
+ install -Dm644 public/static/*.otf -t "$pkgdir"/usr/share/fonts/OTF
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_ttf-pretendard() {
+ install -Dm644 public/static/alternative/*.ttf -t "$pkgdir"/usr/share/fonts/TTF
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+