summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhvksmr19962020-09-10 03:16:15 +0000
committerhvksmr19962020-09-10 03:16:15 +0000
commitcdf55fb4dc8278c00500e4baca7c5a41321ec97d (patch)
treed494299fc67b59df1a255bd03a2a32c5b235369c /PKGBUILD
parent15e7cef6938d954e65da6d9fe257e7c14c3d30cd (diff)
downloadaur-cdf55fb4dc8278c00500e4baca7c5a41321ec97d.tar.gz
0.0.20
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8ccd38d11ae..73919ce69a12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# This file is automatically generated. Do not edit.
pkgname=pretty-exec
-pkgver=0.0.19
-source=(pretty-exec-0.0.19.tar.gz::https://github.com/KSXGitHub/pretty-exec/archive/0.0.19.tar.gz https://raw.githubusercontent.com/KSXGitHub/pretty-exec/master/LICENSE.md)
+pkgver=0.0.20
+source=(pretty-exec-0.0.20.tar.gz::https://github.com/KSXGitHub/pretty-exec/archive/0.0.20.tar.gz https://raw.githubusercontent.com/KSXGitHub/pretty-exec/master/LICENSE.md)
sha1sums=(SKIP SKIP)
# This PKGBUILD is not a full PKGBUILD
# pkgname, pkgver, source, and sha1sums are to be generated
@@ -16,13 +16,16 @@ url='https://github.com/KSXGitHub/pretty-exec'
makedepends=(cargo)
build() {
- cd "$srcdir"/pretty-exec-"$pkgver"
+ cd "$srcdir/pretty-exec-$pkgver"
cargo build --release --locked
}
package() {
- cd "$srcdir"/pretty-exec-"$pkgver"
- install -Dm755 target/release/pretty-exec "$pkgdir"/usr/bin/pretty-exec
- install -Dm644 LICENSE.md "$pkgdir"/usr/share/"$pkgname"/LICENSE.md
+ cd "$srcdir/pretty-exec-$pkgver"
+ install -Dm755 target/release/pretty-exec "$pkgdir/usr/bin/pretty-exec"
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/$pkgname/LICENSE.md"
+ install -Dm644 exports/completion.bash "$pkgdir/usr/share/bash-completion/completions/pretty-exec"
+ install -Dm644 exports/completion.fish "$pkgdir/usr/share/fish/completions/pretty-exec.fish"
+ install -Dm644 exports/completion.zsh "$pkgdir/usr/share/zsh/site-functions/_pretty-exec"
}