summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuke Arms2023-09-09 14:29:52 +0000
committerLuke Arms2023-09-09 14:29:52 +0000
commitbbe40088f3978a16c0f3a9b048b12e8e980727b1 (patch)
treedc8ffb04dfcd543901d6c9f6182e73989ed7eec5 /PKGBUILD
parentfb537e743f91ccd9fe2bf70c02d353627f0aed3c (diff)
downloadaur-bbe40088f3978a16c0f3a9b048b12e8e980727b1.tar.gz
v0.4.24
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32c7811423f4..c519cdceff65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Luke Arms <luke@arms.to>
pkgname=pretty-php
-pkgver=0.4.23
+pkgver=0.4.24
pkgrel=1
-pkgdesc="The opinionated code formatter for PHP"
+pkgdesc="The opinionated PHP code formatter"
arch=('any')
license=('MIT')
url="https://github.com/lkrms/pretty-php"
depends=('php')
-makedepends=('php-sodium' 'git' 'composer' 'jq')
+makedepends=('php-sodium' 'git' 'composer')
source=("${pkgname}::git+https://github.com/lkrms/pretty-php.git#tag=v${pkgver}")
sha256sums=('SKIP')
prepare() {
cd "${srcdir}/${pkgname}"
- composer install --no-plugins --no-interaction
+ rm -rf build/dist
}
build() {
@@ -40,11 +40,9 @@ package() {
}
_phar() {
- local phar
- phar=$(jq -r \
- '.assets[] | select(.type == "phar") | .path' \
- build/dist/manifest.json)
- printf 'build/dist/%s' "$phar"
+ local phar=(build/dist/*)
+ [[ ${#phar[@]} -eq 1 ]] && [[ -x $phar ]] || return
+ printf '%s\n' "$phar"
}
_check_sodium() {