summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhashworks2020-06-18 20:19:44 +0200
committerhashworks2020-06-18 20:30:45 +0200
commitcbd46a3dc0ec2ad3f99d88608f0e10c8135a42a2 (patch)
tree8a98d689326f5938f3f9406d7604cf458807076f /PKGBUILD
parentb3efc2ee749049b7f61713d4d5ed8ab48104f51e (diff)
downloadaur-prismatik.tar.gz
Fix QMAKE buildflags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1658ac22452..cd8e6cb236ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: hashworks <mail@hashworks.net>
+# Contributor: Thore Bödecker <foxxx0@archlinux.org>
pkgname=prismatik
pkgver=5.11.2
-pkgrel=1
+pkgrel=3
pkgdesc="A controller for usb driven LED backlights"
arch=('x86_64')
url="https://github.com/woodenshark/Lightpack"
@@ -11,19 +12,22 @@ depends=('qt5-serialport' 'hicolor-icon-theme')
provides=('lightpack')
install=prismatik.install
source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "fix_includes.patch")
+ "fix_includes.patch"
+ "fix_qmake_buildflags.patch")
sha256sums=('5f3662086965270476b8ea2c014aa0b958afb15b58b5f3000e5f7280386b3022'
- '14c688737d8ba5f128492380c21f9b78c351e59b99375fdc143df52bc2a98781')
+ '14c688737d8ba5f128492380c21f9b78c351e59b99375fdc143df52bc2a98781'
+ '14c7f26ae080ab0449f4ad4ba4c68c0c3dacbbe63bace7da5c4faae9554c4d8f')
prepare() {
cd "Lightpack-${pkgver}"
patch --forward --strip=1 --input="${srcdir}/fix_includes.patch"
+ patch --forward --strip=1 --input="${srcdir}/fix_qmake_buildflags.patch"
cd Software
- qmake -r
}
build() {
cd "Lightpack-${pkgver}/Software"
+ qmake -r
make
}