summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-18 16:09:39 +0200
committerSefa Eyeoglu2022-10-18 16:09:39 +0200
commit988fd415c39ef9a435ccf0aafafd857a7800c707 (patch)
tree46cf1986000e768b125df89a9ac80bb406ead7aa /PKGBUILD
parent6313b67eadf867522647bd5aeae7fbacb0c0086e (diff)
downloadaur-988fd415c39ef9a435ccf0aafafd857a7800c707.tar.gz
upgpkg: prismlauncher-git 1.4.0.r381.g3405fd91-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dff61ff2dbd7..3742aba414a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
_pkgname=prismlauncher
pkgname=${_pkgname}-git
-pkgver=1.4.0.r365.gafaef4e8
+pkgver=1.4.0.r381.g3405fd91
pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64' 'aarch64')
-url="https://github.com/PlaceholderMC/PlaceholderMC"
+url="https://github.com/PrismLauncher/PrismLauncher"
license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
provides=('polymc')
@@ -22,18 +22,18 @@ optdepends=('glfw: to use system GLFW libraries'
'xorg-xrandr: for older minecraft versions'
)
options=(debug)
-source=("PlaceholderMC::git+https://github.com/PlaceholderMC/PrismLauncher.git"
- "libnbtplusplus::git+https://github.com/PlaceholderMC/libnbtplusplus.git")
+source=("git+https://github.com/PrismLauncher/PrismLauncher.git"
+ "git+https://github.com/PrismLauncher/libnbtplusplus.git")
sha256sums=('SKIP'
'SKIP')
pkgver() {
- cd "PlaceholderMC"
+ cd "PrismLauncher"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "PlaceholderMC"
+ cd "PrismLauncher"
git submodule init
git config submodule.depends/libnbtplusplus.url "${srcdir}/libnbtplusplus"
git config submodule.libraries/quazip.active false
@@ -48,7 +48,7 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_APP_BINARY_NAME="${_pkgname}" \
-DLauncher_QT_VERSION_MAJOR="6" \
- -Bbuild -SPlaceholderMC
+ -Bbuild -SPrismLauncher
cmake --build build
}