summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClaudia2023-05-19 00:21:20 +0200
committerClaudia2023-05-19 00:28:59 +0200
commitedcb764f00b3f674681a73d7feaeb07ae4acb6e0 (patch)
tree6094934a091d2a8975971f5bc81f8d6696e49deb /PKGBUILD
parent1a8b7a3cb5c27f7524fc18058a005d9c85c9ed59 (diff)
downloadaur-edcb764f00b3f674681a73d7feaeb07ae4acb6e0.tar.gz
Fix Python deprecations, package correct wheel
Use the proper non-deprecated toolchain for building wheels. Also, add workaround from the Arch Wiki to prevent wheel packaging issues. See also: https://wiki.archlinux.org/title/Python_package_guidelines#Standards_based_(PEP_517)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 94f89fc64cfa..7234942ce86b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=private-internet-access-vpn
pkgver=3.4
-pkgrel=2
+pkgrel=3
pkgdesc="Installs VPN profiles for Private Internet Access Service"
arch=("any")
url="https://www.privateinternetaccess.com/"
license=('GPL')
-depends=('python' 'python-setuptools' 'python-docopt' 'openvpn')
-makedepends=('git')
+depends=('openvpn' 'python' 'python-docopt' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
optdepends=('networkmanager: Enables PIA for Network Manager (needs a openvpn plugin)'
'connman: Enables PIA for Connman')
conflicts=('xawtv') # Both packages install a `pia` executable
@@ -60,9 +60,17 @@ prepare() {
sed 's/_/ /g;s/.ovpn//;s/: /,/;s/[^ ]\+/\L\u&/g;s/\b\([a-z]\{2\}\)\s/\U&/gi' \
>> ../vpn-hosts.txt
+ echo >&2 "Resetting python-pia repository..."
+ git -C "${srcdir}/python-pia" clean -dfx
+
echo >&2 "Done."
}
+build() {
+ cd "${srcdir}/python-pia"
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "${srcdir}"
@@ -82,6 +90,6 @@ package() {
install -D -m 755 openvpn-update-resolv-conf/update-resolv-conf.sh "${pkgdir}/etc/openvpn/update-resolv-conf.sh"
cd "python-pia"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ python -I -m installer --destdir="${pkgdir}" dist/*.whl
}