summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey D2015-07-05 13:16:46 +0300
committerAlexey D2015-07-05 13:16:46 +0300
commitd0a16510a5e70dbacb92156c285b135e725cb0bf (patch)
tree29e632acfa935d5855740f4cc188907368aa3f39 /PKGBUILD
downloadaur-d0a16510a5e70dbacb92156c285b135e725cb0bf.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9216623b44d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=procps-ng-nosystemd
+pkgver=3.3.10
+pkgrel=1
+pkgdesc='Utilities for monitoring your system and its processes'
+url='http://sourceforge.net/projects/procps-ng/'
+license=('GPL' 'LGPL')
+arch=('i686' 'x86_64')
+depends=('ncurses')
+source=("http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-${pkgver}.tar.xz"
+ 'sysctl.conf')
+sha1sums=('484db198d6a18a42b4011d5ecb2cb784a81b0e4f'
+ '674282245d8ab2e09017b8f8cdce20a3ff81e631')
+groups=('base')
+conflicts=('procps' 'procps-ng' 'sysvinit-tools' 'sysctl-default-conf')
+replaces=('procps' 'procps-ng' 'sysvinit-tools' 'sysctl-default-conf')
+provides=('procps' "procps-ng=$pkgver" 'sysvinit-tools')
+install=procps-ng.install
+
+prepare() {
+ cd "${srcdir}/procps-ng-${pkgver}"
+
+ sed 's:<ncursesw/:<:g' -i watch.c
+}
+
+build() {
+ cd "${srcdir}/procps-ng-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --exec-prefix=/ \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --enable-watch8bit
+ make
+}
+
+package() {
+ cd "${srcdir}/procps-ng-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "sysctl.conf" "$pkgdir/etc/sysctl.conf"
+
+ # provided by util-linux
+ rm "${pkgdir}/usr/bin/kill"
+ rm "${pkgdir}/usr/share/man/man1/kill.1"
+}