summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiguel Revilla2019-01-21 09:28:00 +0100
committerMiguel Revilla2019-01-21 09:28:00 +0100
commitb52341ce474b0d9656fc9560b50049fac69389ab (patch)
tree6a7051d6d28d89bbe9a8932e754cd93b68ee723e /PKGBUILD
parente50b8d682e5dcea636940469c305957c9d1d6b30 (diff)
downloadaur-b52341ce474b0d9656fc9560b50049fac69389ab.tar.gz
Applied facl patched from version-to-be 1.3.7 and enabled mod_facl
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 14 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35b0b8a2ea6e..e0d29ffd32c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=proftpd
pkgver=1.3.6
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc='High-performance, scalable FTP server'
arch=('x86_64' 'i686')
@@ -13,13 +13,24 @@ depends=('mariadb-libs' 'postgresql-libs' 'libcap' 'pam' 'hiredis')
backup=('etc/proftpd.conf')
options=('!emptydirs')
source=("ftp://ftp.proftpd.org/distrib/source/${pkgname}-${pkgver}.tar.gz"
+ "https://github.com/proftpd/proftpd/commit/345aa19ee2a98a3612d9b64a49107461455031a0.patch"
+ "https://github.com/proftpd/proftpd/commit/8946c7c07dd5305dfb53d5b43aa63dba649def46.patch"
'proftpd.logrotate' 'proftpd.service'
'proftpd.tmpfiles')
md5sums=('13270911c42aac842435f18205546a1b'
+ '8a122849d7bffb931e83114e610beef0'
+ '41fb8773f6984275bda43446a09d2b2e'
'4d7a3eedc1852d4fa9faafc072fb8320'
'f7e0c3a402a845ba8d546b2801f77ed2'
'907b149a120b046f05647c73502e23c9')
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 < "${srcdir}/345aa19ee2a98a3612d9b64a49107461455031a0.patch"
+ patch -p1 < "${srcdir}/8946c7c07dd5305dfb53d5b43aa63dba649def46.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -27,7 +38,7 @@ build() {
--sbindir=/usr/bin \
--libexecdir=/usr/lib \
--disable-pam \
- --with-modules=mod_sftp:mod_quotatab:mod_quotatab_sql:mod_quotatab_file:mod_tls:mod_ldap:mod_sql:mod_sql_mysql:mod_sql_postgres \
+ --with-modules=mod_sftp:mod_quotatab:mod_quotatab_sql:mod_quotatab_file:mod_tls:mod_ldap:mod_sql:mod_sql_mysql:mod_sql_postgres:mod_facl \
--sysconfdir=/etc \
--localstatedir=/run/proftpd \
--enable-ctrls \
@@ -36,6 +47,7 @@ build() {
--with-libraries=/usr/lib/mysql:/usr/lib/postgresql \
--enable-nls \
--enable-redis \
+ --enable-facl \
--with-systemd
make