summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAbsobel2023-06-27 23:58:46 +0200
committerAbsobel2023-06-27 23:58:46 +0200
commitfb7bc3933347a5da84016f00e502541cd079e7a4 (patch)
treeed33c9a5ed53cf45b6b9e50645431f58fbd0d463 /PKGBUILD
parent96fe9564434f9f9857af1d5b202b38e63ca6112f (diff)
downloadaur-fb7bc3933347a5da84016f00e502541cd079e7a4.tar.gz
1.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03b19590a1c7..a8ee2f89b6b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=projectable
_binname=prj
-pkgver=1.1.0
+pkgver=1.2.0
pkgrel=1
pkgdesc="A TUI file manager built for projects."
arch=('any')
@@ -11,7 +11,7 @@ license=('MIT')
depends=()
makedepends=('cargo')
source=("$pkgname-$pkgver.tar.gz::https://github.com/dzfrias/$pkgname/archive/$pkgver.tar.gz")
-sha256sums=('9add5870d108af8ea9e77b9862541870b48d8fd71c15955181157db514bdaf7a')
+sha256sums=('7cc43db900f016219ca8e742f2f34d7d0389130fcc240d67ab50547a8d268f31')
prepare() {
cd "$pkgname-$pkgver"
@@ -27,12 +27,11 @@ build() {
cargo build --frozen --release --all-features
}
-# Uncomment next release when tests works again, project works fine, the problem come from the tests
-#check() { -
-# cd "$pkgname-$pkgver"
-# export RUSTUP_TOOLCHAIN=stable
-# cargo test --frozen --all-features
-#}
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
package() {
cd "$pkgname-$pkgver"