summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-02-15 20:47:46 +0100
committerSefa Eyeoglu2020-02-15 20:47:46 +0100
commit5bce9bb8a60982cc19bd0215aa245be464770d12 (patch)
treec52b0ac02389fd2093aaead954e7868ac598a329 /PKGBUILD
downloadaur-5bce9bb8a60982cc19bd0215aa245be464770d12.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ef10e197e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=proji
+
+pkgname=${_pkgname}
+pkgver=0.18.1
+pkgrel=1
+pkgdesc="A fast and powerful cli project scaffolding tool"
+arch=("x86_64")
+url="https://github.com/nikoksr/proji"
+license=("custom:MIT")
+
+depends=("glibc")
+makedepends=("go-pie" "golang-golang-x-sys" "golang-golang-x-text" "golang-github-stretchr-testify" "git")
+
+source=("${_pkgname}::git+https://github.com/nikoksr/proji.git#tag=v${pkgver}")
+sha512sums=('SKIP')
+
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ go get -v -t -d ./...
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ go build \
+ -trimpath \
+ -gcflags "all=-trimpath=${PWD}" \
+ -asmflags "all=-trimpath=${PWD}" \
+ -ldflags "-s -w -extldflags ${LDFLAGS}" \
+ ./cmd/proji
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ install -Dm755 "proji" "${pkgdir}/usr/bin/proji"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}