summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-03-10 08:19:41 +0100
committerSefa Eyeoglu2020-03-10 08:19:41 +0100
commitc11a427cb09887db36b43f196700dccfa19a343c (patch)
tree73e0b5d5c77a0bd51cb783f7bbc4dc906e87df2a /PKGBUILD
downloadaur-c11a427cb09887db36b43f196700dccfa19a343c.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7d73203f6e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=proji
+pkgname=${_pkgname}-bin
+pkgver=0.19.2
+pkgrel=1
+pkgdesc="A powerful cross-platform CLI project templating tool"
+arch=("x86_64")
+url="https://github.com/nikoksr/proji"
+license=("custom:MIT")
+depends=("glibc")
+provides=($_pkgname)
+conflicts=($_pkgname)
+install="${pkgname}.install"
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/nikoksr/proji/releases/download/v${pkgver}/proji-Linux-64bit.tar.gz")
+sha512sums=('SKIP')
+
+package() {
+ install -Dm755 "proji" "${pkgdir}/usr/bin/proji"
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}