summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-08-15 22:05:58 +0000
committerGeorge Rawlinson2021-08-15 22:05:58 +0000
commit40bad481f27a87f864b06bdd0b321beabaf1e39b (patch)
tree8e36e586cf21342de40b125f6c1a72fc16b3f24a /PKGBUILD
parent52e63d3a1d30d2a5c24c6501979bad3f6cf13768 (diff)
downloadaur-40bad481f27a87f864b06bdd0b321beabaf1e39b.tar.gz
upgpkg: promscale 0.5.1-2
Add Go flags to ensure package is reproducible.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a05aaaf214c..b9af9d5a316c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=promscale
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="An open source analytical platform for Prometheus metrics"
arch=('x86_64')
url="https://github.com/timescale/promscale"
@@ -30,6 +30,12 @@ prepare() {
build() {
cd "$pkgname-$pkgver"
+
+ # set Go flags
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+
go build -v \
-buildmode=pie \
-trimpath \