summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRodrigo C. Gryzinski2019-10-19 08:02:38 -0300
committerRodrigo C. Gryzinski2019-10-19 08:02:38 -0300
commit3afe0540f27fe95d64db93a59db2570d4e375730 (patch)
treee06bb1e4488343a1a2e785475a145af53c23d1ce /PKGBUILD
parented57a729724615ee2e864ae8144fc53cf7f48ed7 (diff)
downloadaur-propellor.tar.gz
Update to 5.9.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 9 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a10a53e79550..2b1bf04d5efb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,25 @@
+# Maintainer: Rodrigo Gryzinski <rogryza@gmail.com>
# Maintainer: Zihao Wang <dev@wzhd.org>
pkgname=propellor
-pkgver=3.3.0
+pkgver=5.9.1
pkgrel=1
pkgdesc="property-based host configuration management in haskell"
url="https://propellor.branchable.com/"
license=("custom:BSD2")
arch=('i686' 'x86_64')
-depends=("cabal-install" "ghc=8.0.1" "git" "gnupg" "gmp" "libffi"
- "haskell-async" "haskell-missingh" "haskell-hslogger" "haskell-unix-compat"
- "haskell-ansi-terminal" "haskell-hackage-security" "haskell-ifelse" "haskell-network"
- "haskell-mtl" "haskell-transformers-base" "haskell-exceptions" "haskell-stm"
- "haskell-text")
-source=("git+https://github.com/joeyh/propellor.git#tag=$pkgver")
-sha256sums=('SKIP')
+depends=("stack")
+source=("https://git.joeyh.name/index.cgi/propellor.git/snapshot/propellor-$pkgver.tar.gz")
+sha256sums=('4ac697c1651f48318b08c0d131038bcbe8af27e28632abf065a7cca598d5f1c1')
build() {
- cd propellor
+ cd "${srcdir}/${pkgname}-${pkgver}"
- runhaskell Setup configure -O --prefix=/usr --docdir="/usr/share/doc/$pkgname" \
- --libsubdir=\$compiler/site-local/\$pkgid \
- --enable-library-profiling --enable-shared
- runhaskell Setup build
- runhaskell Setup haddock --hoogle --html
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+ stack build --ghc-options -O2
}
package() {
- cd propellor
+ cd "${srcdir}/${pkgname}-${pkgver}"
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
- install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
- ln -s "/usr/share/doc/${pkgname}/html" "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
-
- runhaskell Setup copy --destdir="$pkgdir"
-
- rm -f "${pkgdir}/usr/bin/propellor-config"
-
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ stack install --local-bin-path "${pkgdir}/usr/bin"
}