summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-11-19 00:29:13 +0100
committerMaxime “pep” Buquet2019-11-19 00:36:23 +0100
commit3a25cea5e7bd04f0571f1019f16498a481960591 (patch)
treeece7f60b000b0553dfbb7ec9dc79a2c1ea5475df /PKGBUILD
parent104d1e29f1f3caa8d2c1f2c1ca48735f52a944f0 (diff)
downloadaur-3a25cea5e7bd04f0571f1019f16498a481960591.tar.gz
Move pkgver() below meta stuff
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a83a69ca8c57..9f50e8631f6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,6 @@
pkgname=prosody-hg
pkgrel=1
pkgver=r9637+.b8301ba2c437+
-pkgver() {
- cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
-}
pkgdesc="Lightweight and extensible Jabber/XMPP server written in Lua (development build from trunk-branch)"
arch=('i686' 'x86_64' 'armv7h')
url="https://prosody.im/"
@@ -39,6 +35,11 @@ source=("prosody-hg::hg+https://hg.prosody.im/trunk"
'sysuser.conf'
'prosody.service')
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
prepare() {
cd ${pkgname}