summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPolichronucci2016-03-10 04:12:30 +0200
committerPolichronucci2016-03-10 04:12:30 +0200
commitdc2ec320e78392af12923d5aa322eeb8ed0fd078 (patch)
treecfe9d4353758388230712f5e4bbed68dc8501fca /PKGBUILD
downloadaur-dc2ec320e78392af12923d5aa322eeb8ed0fd078.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bf938d393d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Polichronucci <nick AT discloud DOT eu>
+pkgname=prosody-mod-auth-dovecot
+pkgver=2014_03_28
+pkgrel=1
+pkgdesc="Prosody authentication plugin which uses Dovecot as the backend"
+arch=('any')
+url="https://modules.prosody.im/mod_auth_dovecot.html"
+license=('MIT')
+depends=('prosody')
+
+source=("https://hg.prosody.im/prosody-modules/raw-file/cb74e4ab13f0/mod_auth_dovecot/auth_dovecot/mod_auth_dovecot.lua"
+ "https://hg.prosody.im/prosody-modules/raw-file/cb74e4ab13f0/mod_auth_dovecot/auth_dovecot/sasl_dovecot.lib.lua")
+
+md5sums=("d2314ee5fd6913d505fd5429244a1aa8"
+ "14eb927b9c92801d7005c119a4acc079")
+
+package() {
+ install -Dm 644 "mod_auth_dovecot.lua" "${pkgdir}/usr/lib/prosody/modules/mod_auth_dovecot.lua"
+ install -Dm 644 "sasl_dovecot.lib.lua" "${pkgdir}/usr/lib/prosody/modules/sasl_dovecot.lib.lua"
+}