summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYves G2020-04-15 21:24:54 +0200
committerYves G2020-04-15 21:27:51 +0200
commit30e9be8678f53cd56e8c1e4f8fbe445ffdfc23f4 (patch)
tree42d5ad59e04400102cfed1ea23f604540ed256c5 /PKGBUILD
parentc88e50d79be3c7481297b861482796161286957b (diff)
downloadaur-30e9be8678f53cd56e8c1e4f8fbe445ffdfc23f4.tar.gz
deprecated upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0547be71d246..76927f799b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=prosody-mod-auth-external-hg
pkgver=tip
-pkgrel=1
-pkgdesc="Authenticate Prosody users using a custom binary/script"
+pkgrel=2
+pkgdesc="Authenticate Prosody users using a custom binary/script (DEPRECATED UPSTREAM)"
arch=('any')
url="https://modules.prosody.im/mod_auth_external.html"
license=('MIT')
-depends=('prosody>=0.8' 'lua51-lpty')
+depends=('prosody' 'lua52-lpty')
makedepends=('mercurial')
source=("hg+https://hg.prosody.im/prosody-modules/")
sha1sums=('SKIP')
@@ -18,8 +18,8 @@ pkgver() {
}
package() {
- cd "${srcdir}/prosody-modules/mod_auth_external"
+ cd "${srcdir}/prosody-modules/mod_auth_external_insecure"
mkdir -p "${pkgdir}/usr/lib/prosody/modules/" "${pkgdir}/usr/share/doc/${pkgname}"
- cp mod_auth_external.lua "${pkgdir}/usr/lib/prosody/modules/"
+ cp mod_auth_external_insecure.lua "${pkgdir}/usr/lib/prosody/modules/mod_auth_external.lua"
cp -r examples README.markdown "${pkgdir}/usr/share/doc/${pkgname}/"
}