summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2017-10-01 23:30:13 +0300
committerChristoph Gysin2017-10-01 23:30:27 +0300
commitd4ae8c0142b43a5d0dd7dcc312ea5e8da4b0a5b8 (patch)
tree9d7d2ae8d1b85067b0828694092143892e4f7852 /PKGBUILD
parent5c941eb89727b22d0adb9529e2f07ded2abfb4d0 (diff)
downloadaur-d4ae8c0142b43a5d0dd7dcc312ea5e8da4b0a5b8.tar.gz
fix version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5fac83b4015..a6e3633cc945 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=protobuf-rust-git
-pkgver=1.0.24.511
+pkgver=1.4.1.12.gdf787b8
pkgrel=1
pkgdesc="Rust Support for Google's protocol buffers"
arch=('x86_64' 'i686')
@@ -15,7 +15,7 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD)
+ git describe --tags | sed -e 's/-/./g' -e 's/^v//'
}
build() {