summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2022-01-07 19:49:00 +0200
committerStelios Tsampas2022-01-07 19:49:00 +0200
commitbede320f9fdd29531b435c1c43572cef9d1af20f (patch)
tree58ed2873bbcefa3b5ad7628f1e4c11a3c0f294c9 /PKGBUILD
parentf174762260433d2828eb7b451eabaa0fe8373d0f (diff)
downloadaur-bede320f9fdd29531b435c1c43572cef9d1af20f.tar.gz
fixup: `as` wrapper
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2031af06ffd..951f202b871e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgver=6.3.8
_geckover=2.47.2
_monover=6.4.1
_asyncver=1.9.2
-pkgrel=4
+pkgrel=5
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components"
url="https://github.com/ValveSoftware/Proton"
@@ -143,12 +143,13 @@ noextract=(
)
_make_wrappers () {
- local _i686=(i686 "-m32" "-melf_i386")
- local _x86_64=(x86_64 "" "")
+ # _arch prefix gcc ld as
+ local _i686=( "i686" "-m32" "-melf_i386" "--32")
+ local _x86_64=("x86_64" "-m64" "-melf_x86_64" "--64")
local _opts=(_i686 _x86_64)
declare -n _opt
for _opt in "${_opts[@]}"; do
- for l in ar as ranlib nm; do
+ for l in ar ranlib nm; do
ln -s /usr/bin/$l wrappers/${_opt[0]}-pc-linux-gnu-$l
done
for t in gcc g++; do
@@ -161,6 +162,10 @@ EOF
#!/usr/bin/bash
/usr/bin/ld ${_opt[2]} "\$@"
EOF
+ install -Dm755 /dev/stdin wrappers/${_opt[0]}-pc-linux-gnu-as <<EOF
+#!/usr/bin/bash
+/usr/bin/as ${_opt[3]} "\$@"
+EOF
done
}
@@ -305,8 +310,8 @@ build() {
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
# `-O2` is adjusted to `-O3` since AVX is disabled
- export CFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
- export CXXFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
+ export CFLAGS="-O2 -march=nocona -pipe -mtune=core-avx2"
+ export CXXFLAGS="-O2 -march=nocona -pipe -mtune=core-avx2"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# If using -march=native and the CPU supports AVX, launching a d3d9