summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-26 00:26:04 +0200
committerStelios Tsampas2024-01-26 00:26:04 +0200
commit994292b68bbd2ad3e18e899f272156f4a3849d28 (patch)
tree833988394014fefc3514bbccaceda05ec5120ad3 /PKGBUILD
parent4439043ca4a33599af3bc84adcdf186b1dc87383 (diff)
downloadaur-994292b68bbd2ad3e18e899f272156f4a3849d28.tar.gz
[proton*] Remove personal builds
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 15 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd52b9656b7d..83b98da3173c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,12 @@
# Maintainer: loathingkernel <loathingkernel _a_ gmail _d_ com>
-# By default use the same optimizations used by Valve and ignore makepkg,
-# to avoid build failures due to options incompatible with MingW cross-compilation.
-# If you set this switch to 'true', you are on your own.
-: ${_system_cflags:=false}
-
pkgname=proton-ge-custom
_srctag=GE-Proton8-27
_commit=989b502c4aed6efd8b210b785c163e9c6c6e233e
pkgver=${_srctag//-/.}
_geckover=2.47.3
_monover=8.1.0
-pkgrel=1
+pkgrel=2
epoch=2
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components, GloriousEggroll's custom build"
url="https://github.com/GloriousEggroll/proton-ge-custom"
@@ -101,9 +96,6 @@ source=(
0005-AUR-Strip-binaries-early.patch
0006-AUR-Fix-hwnd-redefinition.patch
)
-# Optional patches
-source+=(
-)
noextract=(
wine-gecko-${_geckover}-{x86,x86_64}.tar.xz
wine-mono-${_monover}-x86.tar.xz
@@ -188,14 +180,16 @@ build() {
--proton-sdk-image="" \
--build-name="${pkgname}"
- if [[ x"${_system_cflags::1}" != "xt" ]] ; then
- unset CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS
- fi
- : ${CFLAGS:="-O2 -march=nocona -mtune=core-avx2 -pipe"}
- : ${CXXFLAGS:="-O2 -march=nocona -mtune=core-avx2 -pipe"}
- : ${RUSTFLAGS:="-C opt-level=2 -C target-cpu=nocona"}
- : ${LDFLAGS:="-Wl,-O1,--sort-common,--as-needed"}
- export CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local march="${flags["-march"]:-nocona}"
+ local mtune="${flags["-mtune"]:-core-avx2}"
+
+ CFLAGS="-O2 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
+ CXXFLAGS="-O2 -march=$march -mtune=$mtune -pipe -fno-semantic-interposition"
+ RUSTFLAGS:="-C opt-level=2 -C target-cpu=$march"
+ LDFLAGS:="-Wl,-O1,--sort-common,--as-needed"
# If using -march=native and the CPU supports AVX, launching a d3d9
# game can cause an Unhandled exception. The cause seems to be the
@@ -208,8 +202,10 @@ build() {
# https://bugs.winehq.org/show_bug.cgi?id=43516
# AVX is "hard" disabled for 32bit in any case.
# AVX2 for both 32bit and 64bit is disabled below.
- export CFLAGS+=" -mno-avx2"
- export CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2"
+ CXXFLAGS+=" -mno-avx2"
+
+ export CFLAGS CXXFLAGS RUSTFLAGS LDFLAGS
export RUSTUP_TOOLCHAIN=stable
export CARGO_HOME="${SRCDEST}"/proton-cargo