summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStelios Tsampas2021-01-18 19:55:17 +0200
committerStelios Tsampas2021-01-18 19:55:17 +0200
commit26abb36277b582ba86ffb706ce7f80845f8d6ce7 (patch)
treeeb48bad57b9a27a854ccc6d6d200c0d151d1a820 /PKGBUILD
parentdac1371ade1e6131b8519a90f4c7d0dd1a578c12 (diff)
downloadaur-26abb36277b582ba86ffb706ce7f80845f8d6ce7.tar.gz
Add dxvk async patch. Optional
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64e604491cec..3be2752d7e47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _commit=
pkgver=${_srctag//-/.}
_geckover=2.47.1
_monover=5.1.1
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Compatibility tool for Steam Play based on Wine and additional components. Monolithic distribution"
arch=(x86_64)
@@ -115,6 +115,7 @@ source=(
proton-unfuck_makefile.patch
proton-disable_lock.patch
proton-user_compat_data.patch
+ dxvk-async.patch
dxvk-extraopts.patch
vkd3d-extraopts.patch
)
@@ -174,6 +175,11 @@ prepare() {
patch -p1 -i "$srcdir"/proton-disable_lock.patch
patch -p1 -i "$srcdir"/proton-user_compat_data.patch
+ # Uncomment to enable dxvk async patch.
+ # Enable at your own risk. If you don't know what it is,
+ # and its implications, leave it as is. You have been warned.
+ # I am not liable if anything happens to you by using it.
+ #patch -p1 -i "$srcdir"/dxvk-async.patch
# Uncomment to enable extra optimizations
# Patch crossfiles with extra optimizations from makepkg.conf
patch -p1 -i "$srcdir"/dxvk-extraopts.patch
@@ -198,6 +204,7 @@ prepare() {
# Since Wine 5.16 AVX is supported. Testing showed 32bit applications
# crashing with AVX regardless, but 64bit applications worked just fine.
# So disable AVX only for the 32bit binaries and AVX2 for the 64bit.
+ # AVX2 seems to degrade performance. So disregard the above.
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
@@ -322,5 +329,6 @@ sha256sums=('SKIP'
'5722c9669b02592cc53adda14a9e256701ed88f875dc00d24b5c5705cf6c33f5'
'8263a3ffb7f8e7a5d81bfbffe1843d6f84502d3443fe40f065bcae02b36ba954'
'20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
+ '36aaba6847e4577df4a496d88c11b4b7049773f1f2b90aa4545093e16d5c6066'
'23cba1756adc4a76de963414994ffc964047ab1d6f1949fe8133135a91ac0473'
'7c5f9c20e41c0cd7d0d18867950a776608cef43e0ab9ebad2addb61e613fe17a')