summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Stryker2022-07-01 15:02:25 -0400
committerJason Stryker2022-07-01 15:02:25 -0400
commita1f2466033c421768cbce97e3a57e157277991c1 (patch)
tree581462a7f546a643bf41dd0eb8c95a7d094fd3a2 /PKGBUILD
parent54ae7719806c4a279a7886791bd731925762cbfd (diff)
downloadaur-a1f2466033c421768cbce97e3a57e157277991c1.tar.gz
use tags for versioning instead of setup.py
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b695f6a019f6..4b894d6831b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jason Stryker <public at jasonstryker dot com>
pkgname=protontricks-git
-pkgver=1.8.2.dev3+gbe3805b
+pkgver=1.8.2.r3.8bed483
pkgrel=1
pkgdesc="A simple wrapper that does winetricks things for Proton enabled games. (Git Version)"
arch=('any')
@@ -20,7 +20,7 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- python3 setup.py --version
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
build() {