summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorProton Technologies AG2021-05-28 17:28:12 +0100
committerProton Technologies AG2021-05-28 17:28:12 +0100
commit7f6cf83e9fa4455acd184dbb025b9e64dd17d409 (patch)
tree7bc4c39d29248fdad37fea80fc0ea909d8437287 /PKGBUILD
downloadaur-7f6cf83e9fa4455acd184dbb025b9e64dd17d409.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15e5e63c334d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Proton Technologies AG <opensource at proton dot me>
+# Maintainer: Alexandru Cheltutior <acrandom at pm dot me>
+pkgname=protonvpn-gui
+_gitpkgname=linux-app
+pkgver=0.7.3
+pkgrel=1
+pkgdesc="ProtonVPN Graphical User Interface"
+arch=("any")
+url="https://github.com/ProtonVPN/"
+license=("GPL3")
+groups=("ProtonVPN")
+depends=("python-protonvpn-nm-lib>=3.2.0" "python-protonvpn-nm-lib<3.3.0" "python-gobject" "python-psutil" "gtk3")
+optdepends=("libappindicator-gtk3")
+makedepends=("python-setuptools")
+source=("https://github.com/ProtonVPN/linux-app/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('38376a774741386d2f0962aca346b07763e1976d1cc774a5657107b355c1d8b1')
+validpgpkeys=("A884 41BD 4864 F95B EE08 E63A 71EB 4740 1994 0E11")
+
+build() {
+ cd "$_gitpkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_gitpkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}