summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFélix Piédallu2024-04-11 16:37:13 +0200
committerFélix Piédallu2024-04-11 16:51:05 +0200
commitf154907677155b4fee4ae499e8e8572be2d97fc4 (patch)
tree1d7741b7902d324090f7a7f3c2e8439c1f7772f2 /PKGBUILD
parent92cbd19a9e130a77eaeb0bd4d66287003f8a5cee (diff)
downloadaur-f154907677155b4fee4ae499e8e8572be2d97fc4.tar.gz
Bump pkgver, reduce diff with repo package
Fix build: remove old cherry-pick, add new patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c20c02f025f3..212ef78a8386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Salamandar <felix@piedallu.me>
pkgname=prusa-slicer-git
-pkgver=2.6.0.beta4.r1.gdbc2584d8
+pkgver=2.7.4
pkgrel=1
-pkgdesc='G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)'
+pkgdesc="G-code generator for 3D printers (Prusa fork of Slic3r) (git version)"
arch=('i686' 'x86_64' 'armv6' 'armv6h' 'armv7h')
-url='https://github.com/prusa3d/PrusaSlicer'
+url="https://github.com/prusa3d/PrusaSlicer"
license=('AGPL3')
makedepends=(
'git'
@@ -35,9 +35,11 @@ depends=(
source=(
"git+${url}"
+ "fix_num_constrexpr.patch"
)
sha256sums=(
'SKIP'
+ '91d198af5eecaf6d1a71ad8b59f03e4fa7cefb02c714b3a26978ac8772f8296e'
)
conflicts=('prusa-slicer')
@@ -48,8 +50,8 @@ pkgver() {
prepare() {
cd "PrusaSlicer"
- # Repair gcc13 build
- git cherry-pick "72f6a4e7c7dccc47f203ce8c27b3022c6d7743e8"
+ # Repair clang15 build
+ patch --forward --strip=1 --input=../fix_num_constrexpr.patch
rm "$srcdir/PrusaSlicer/cmake/modules/FindEXPAT.cmake"
}