summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2020-10-10 09:39:20 +0300
committerCaleb Maclennan2020-10-10 09:39:20 +0300
commitaf0f2b73fdfd098d029910d9d9202e22ea75a9bf (patch)
tree3850afe7feaeb243f8c64f51e11da59996f6ad06 /PKGBUILD
parent03f1742dc7892e84b58d6573b1b8ce0a66e2d029 (diff)
downloadaur-af0f2b73fdfd098d029910d9d9202e22ea75a9bf.tar.gz
upgpkg: psautohint 22.1.1-2
Adopt, fix build dependency (PyPi package has SCM bits taken care of)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17d65c35b009..e1e45eb5e851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,16 @@
-# Maintainer:
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+
pkgname=psautohint
pkgver=2.1.1
-pkgrel=1
+pkgrel=2
epoch=2
-pkgdesc="A standalone version of AFDKO’s autohinter"
+pkgdesc='A standalone version of AFDKO’s autohinter'
arch=('x86_64')
-url="https://github.com/adobe-type-tools/psautohint"
+url="https://github.com/adobe-type-tools/$pkgname"
license=('Apache')
-depends=('python-lxml' 'python-fonttools' 'python-fs')
-makedepends=('python-setuptools-scm')
+depends=('python-fonttools' 'python-fs' 'python-lxml')
+makedepends=('python-setuptools')
source=("https://pypi.org/packages/source/${pkgname:0:1}/$pkgname/$pkgname-$pkgver.zip")
sha256sums=('c41253b7a5566d052e92c90ecce86b719342fef4697498b8e64d2b90e1feb89c')
@@ -21,6 +22,5 @@ build() {
package() {
cd "$pkgname-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
-
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}