summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Schwan2018-06-13 11:11:41 +0200
committerCarl Schwan2018-06-13 11:11:41 +0200
commit07be0ab546fcb1abb98ec423f46ac417fc56eff1 (patch)
tree95e9c6c3269f620e9e4224120495ebef1d9de17c /PKGBUILD
downloadaur-07be0ab546fcb1abb98ec423f46ac417fc56eff1.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23a43ebc79ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Schwan Carl <schwancarl at protonmail dot com>
+
+pkgname=pseuco-ide
+pkgver=v2.0.0
+pkgrel=1
+pkgdesc="An IDE for the pseuCo programming language written in Kotlin.
+Uses the pseuco-java-compiler internally."
+arch=('any')
+url="https://dgit.cs.uni-saarland.de/pseuco/pseuco-ide/"
+depends=('jdk')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+source=("https://dgit.cs.uni-saarland.de/pseuco/pseuco-ide/-/jobs/artifacts/master/download?job=jar"
+ "pseuco-ide.desktop"
+ ".install")
+sha256sums=('SKIP'
+ '87186ce1e69f6737c02929ec3fa5898d795a567200b6fa5ff3eee40a55a78df7'
+ 'SKIP')
+
+package() {
+ cd "${srcdir}"
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm0755 "${pkgname}-2.0.0-alpha.jar" "${pkgdir}/usr/share/java/${pkgname}/${pkgname}.jar"
+}