summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPopolon2021-04-14 21:21:04 +0200
committerPopolon2021-04-14 21:21:04 +0200
commit68911e0b0866d080e1bfcd8ba98bc9fb1900f64e (patch)
treefdc9637fd70da4e86da4efba1dce3dcd169e6e7f /PKGBUILD
downloadaur-68911e0b0866d080e1bfcd8ba98bc9fb1900f64e.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..370bdd1513f0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Popolon <popolon@popolon.org>
+
+pkgname=psgplay-git
+_pkgname=psgplay
+pkgver=0.3
+pkgrel=1
+pkgdesc="Music player and emulator for the Atari ST Programmable Sound Generator (PSG) YM2149 and files in the SNDH archive."
+arch=('i686' 'x86_64' 'armv7h' 'armv8' 'riscv32' 'riscv64')
+url="https://github.com/frno7/psgplay"
+license=('GPL-2.0' 'LGPL-2.1' 'MIT')
+depends=('alsa-lib')
+source=("git+https://github.com/frno7/${_pkgname}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make ALSA=1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm644 "licence/GPL-2.0" "${pkgdir}/usr/share/licenses/${_pkgname}/GPL-2.0"
+ install -Dm644 "licence/LGPL-2.1" "${pkgdir}/usr/share/licenses/${_pkgname}/LGPL-2.1"
+ install -Dm644 "licence/MIT" "${pkgdir}/usr/share/licenses/${_pkgname}/MIT"
+ install -Dm755 psgplay "${pkgdir}/usr/bin/psgplay"
+}
+