summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPiotr Gorski2020-06-10 17:59:53 +0200
committerPiotr Gorski2020-06-10 17:59:53 +0200
commitb6e0a28b15a0d1327a1b4ebf45ce607ba900e4ea (patch)
tree74620db08157044bef8a7c49a82b9a45fafcf735 /PKGBUILD
parent512b8b1ef9db20e353bc6a7559c5d574c679dfc9 (diff)
downloadaur-b6e0a28b15a0d1327a1b4ebf45ce607ba900e4ea.tar.gz
Smoothing
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03f45b815706..749e4cb7a8b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.4.1123.r1151.g2170e90
+pkgver=1.4.1399.r1151.g2170e90
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)"
url="https://psi-plus.com"
@@ -47,15 +47,10 @@ prepare() {
}
build() {
- cd psi
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPSI_PLUS=ON -DCHAT_TYPE=WEBENGINE ..
- make
+ cmake -B build -S psi -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPSI_PLUS=ON -DCHAT_TYPE=WEBENGINE ..
+ cmake --build build
}
package() {
- cd psi/build
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}