summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey D2016-05-27 15:17:14 +0300
committerAlexey D2016-05-27 15:17:14 +0300
commitc2b4c3b8c05aa3fdcfd8974f985b25ea8020aeb4 (patch)
treec1895875a9a19499722a4343b442b5a4abe78f37 /PKGBUILD
parentd90f0447f71b881bbf63737c0af87be683c276e6 (diff)
downloadaur-c2b4c3b8c05aa3fdcfd8974f985b25ea8020aeb4.tar.gz
new version scheme
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82b592a7f660..3753427a8c40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Joker-jar <joker-jar@yandex.ru>
pkgname="psi-plus-git"
-pkgver=0.16.559
+pkgver=0.16.559.574
pkgrel=1
pkgdesc="Psi+ is a powerful Jabber client (Qt, C++) designed for the Jabber power users"
url="http://psi-plus.com"
@@ -27,7 +27,11 @@ md5sums=('SKIP'
pkgver() {
cd "$srcdir"/psi-plus
- git describe --tags | cut -d - -f 1-2 --output-delimiter=.
+ PSI_PLUS_REVISION="$(git describe --tags | cut -d - -f 2)"
+ PSI_PLUS_TAG="$(git describe --tags | cut -d - -f 1)"
+ PSI_REVISION="$(cd "$srcdir"/psi && git describe --tags | cut -d - -f 2)"
+
+ echo "${PSI_PLUS_TAG}.${PSI_PLUS_REVISION}.${PSI_REVISION}"
}
prepare() {