summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgilcu32022-09-30 11:50:41 +0200
committergilcu32022-09-30 11:50:41 +0200
commit1f0d96318a4754f1a3b74e9936da7c165c196aa2 (patch)
tree3f012e33e21578d2430c1920690e90e1d282f9a0 /PKGBUILD
parente64e58f0ddd7b26b7dbbfc63e677e1c4a854d511 (diff)
downloadaur-1f0d96318a4754f1a3b74e9936da7c165c196aa2.tar.gz
added support for server
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4ac54f11e550..759158c47f35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,25 @@
_pkgname=psiphon-tunnel-core
pkgname="$_pkgname-git"
pkgver=2.0.27.r3656.3b2cfbca
-pkgrel=2
+pkgrel=3
epoch=3
pkgdesc='Psiphon Tunnelling Proxy'
arch=('i686' 'x86_64')
url="https://github.com/Psiphon-Labs/psiphon-tunnel-core"
license=('GPL3')
makedepends=('go')
-conflicts=('psiphon-console-client')
+conflicts=('psiphon-console-client' 'psiphon-server')
source=("git+$url.git"
- "client.conf"
+ "client.config"
"psiphon-client.service"
+ "psiphon-server.service"
)
install=psiphon.install
-backup=('etc/psiphon/client.conf' 'usr/lib/systemd/user/psiphon-client.service')
+backup=('etc/psiphon/client.config' 'usr/lib/systemd/user/psiphon-client.service' 'usr/lib/systemd/user/psiphon-server.service')
sha256sums=('SKIP'
'c2c414831ad29bdeecd00313c473fbaa448f4750e70df1c10e863870bde179aa'
'6711a12112a594ba70bbae51c66ee23302e08c54c4e059c92b67adba9451c037'
- )
-
-
+ '373c1eb939118055f799237df3e665680b8dc4b4a281505cce32e957a9554c56')
pkgver() {
@@ -42,6 +41,7 @@ export CGO_CXXFLAGS="$CXXFLAGS"
export CGO_LDFLAGS="$LDFLAGS"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
console_binary=psiphon-console-client
+server_binary=psiphon-server
build() {
export GOPATH=$srcdir/go
@@ -49,12 +49,16 @@ build() {
rm -rf "${GOPATH}/src/github.com/Psiphon-Labs/${_pkgname}"
ln -srf "$srcdir/${_pkgname}/" "${GOPATH}/src/github.com/Psiphon-Labs/${_pkgname}"
- # Modified to disable quic disabled (it is not compatible with current go version 1.19)
+ # Modified to disable quic-go (it is not compatible with current go version 1.19)
go build -tags "PSIPHON_DISABLE_QUIC" -o bin/$console_binary "github.com/Psiphon-Labs/$_pkgname/ConsoleClient"
+ go build -tags "PSIPHON_DISABLE_QUIC" -o bin/$server_binary "github.com/Psiphon-Labs/$_pkgname/Server"
}
package() {
install -Dm755 "$srcdir/bin/$console_binary" "$pkgdir/usr/bin/$console_binary"
- install -Dm644 "$srcdir/client.conf" "$pkgdir/etc/psiphon/client.conf"
+ install -Dm755 "$srcdir/bin/$server_binary" "$pkgdir/usr/bin/$server_binary"
+ ln -srf "$pkgdir/usr/bin/psiphon-server" "$pkgdir/usr/bin/psiphond"
+ install -Dm644 "$srcdir/client.config" "$pkgdir/etc/psiphon/client.config"
install -Dm644 "$srcdir/psiphon-client.service" "$pkgdir/usr/lib/systemd/user/psiphon-client.service"
+ install -Dm644 "$srcdir/psiphon-server.service" "$pkgdir/usr/lib/systemd/user/psiphon-server.service"
}