summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxantares2015-06-08 23:16:33 +0200
committerxantares2015-06-08 23:16:33 +0200
commit0e65d6608212545409a2055bee0b2e1afcaa1fdc (patch)
treed2f36cb70edd0385ee2f0c308a76c5de3041a3e9 /PKGBUILD
downloadaur-psp-libtremor.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3fe50b7c3132
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: xantares <xantares09 at hotmail dot com>
+
+pkgname=psp-libtremor
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Integer-only, fully Ogg Vorbis compliant software decoder library (psp)"
+arch=(any)
+url="http://www.xiph.org/vorbis/"
+license=('BSD')
+groups=('psp')
+depends=('psp-sdk')
+makedepends=('psp-gcc')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("git+https://github.com/pspdev/psp-ports.git")
+md5sums=('SKIP')
+
+
+build()
+{
+ cd "$srcdir/psp-ports/libTremor"
+ sh autogen.sh
+ make distclean # autogen calls configure
+ export LDFLAGS="-L$(psp-config --pspsdk-path)/lib -L$(psp-config --psp-prefix)/lib -lc -lpspuser"
+ export LIBS="-lc -lpspuser"
+ mkdir -p build-psp && pushd build-psp
+ ../configure --prefix=/usr/psp --host=psp
+ make
+}
+
+package()
+{
+ cd "$srcdir/psp-ports/libTremor/build-psp"
+ make install DESTDIR="$pkgdir"
+}
+