summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxantares2015-07-02 11:51:38 +0200
committerxantares2015-07-02 11:51:38 +0200
commit5cf594fd5bc9cad2bbabca899a01fb1b6bbf3ccf (patch)
tree3dc04ccf1c53ad31fb4ff6bca2094e7f346b038e /PKGBUILD
parent792d272e61cba60a24095ee07c277bcc28f8a56a (diff)
downloadaur-5cf594fd5bc9cad2bbabca899a01fb1b6bbf3ccf.tar.gz
put patch in sources
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4629cf74f185..e8ac7a41af0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,15 +8,16 @@ license=('GPL')
groups=('psp')
makedepends=('psp-gcc-base' 'psp-binutils' 'psp-sdk-base')
options=('!buildflags' '!strip' 'staticlibs')
-source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz")
-md5sums=('e5488f545c46287d360e68a801d470e8')
+source=("ftp://sourceware.org/pub/newlib/newlib-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch")
+md5sums=('e5488f545c46287d360e68a801d470e8'
+ 'SKIP')
prepare ()
{
cd "$srcdir/newlib-$pkgver"
rm -rf newlib/libc/sys/psp/
- wget -c https://raw.githubusercontent.com/pspdev/psptoolchain/master/patches/newlib-$pkgver-PSP.patch
- patch -p1 -i newlib-$pkgver-PSP.patch
+ patch -p1 -i "$srcdir"/newlib-$pkgver-PSP.patch
}
build()