summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxantares2015-06-08 23:28:57 +0200
committerxantares2015-06-08 23:28:57 +0200
commitb97f299fa5cf144cac4f146ce6ac524f0dd77593 (patch)
treeb9bf946d5ce98e307526091bfa08a3b69c2441a2 /PKGBUILD
downloadaur-b97f299fa5cf144cac4f146ce6ac524f0dd77593.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e23350d30710
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: xantares <xantares09 at hotmail dot com>
+
+pkgname=psp-pspirkeyb
+pkgver=0
+pkgrel=1
+pkgdesc="This is a library for using IRDA keyboards with Playstation Portable (psp)"
+arch=(any)
+url="https://github.com/pspdev/psp-ports"
+license=('GPL')
+groups=('psp')
+depends=('psp-sdk')
+makedepends=('psp-gcc' 'git')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("git+https://github.com/pspdev/psp-ports.git"
+ 0001-Use-PSPDIR-var-in-pspirkeyb-pspgl.patch)
+md5sums=('SKIP' 'SKIP')
+
+
+prepare()
+{
+ cd "$srcdir/psp-ports"
+ patch -p1 -i "$srcdir"/0001-Use-PSPDIR-var-in-pspirkeyb-pspgl.patch
+}
+
+build()
+{
+ cd "$srcdir/psp-ports/pspirkeyb"
+ make
+}
+
+package()
+{
+ cd "$srcdir/psp-ports/pspirkeyb"
+ make install PSPDIR="$pkgdir"/usr/psp
+}
+