summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGarionion2022-02-19 14:31:50 +0100
committerGarionion2022-02-19 14:31:50 +0100
commit237632e1e6ae09a7e76e365ddd085fc89ce6eca9 (patch)
tree787019d9069d58e86434157574c4a6763700b323 /PKGBUILD
parentb3d7f7d461280d17a980637d1a3ef65ed8c71e87 (diff)
downloadaur-237632e1e6ae09a7e76e365ddd085fc89ce6eca9.tar.gz
add some dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc261e0f8b9a..9e58527aa8c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# contributor: yochananmarqos (thank you very much)
pkgname=psst-git
pkgver=r406.1627cd4
-pkgrel=3
+pkgrel=4
pkgdesc="Fast and multi-platform Spotify client with native GUI"
arch=("x86_64")
options=(!lto)
url="https://github.com/jpochyla/psst"
license=('MIT')
-depends=('gtk3' 'openssl')
-makedepends=('cargo' 'git')
+depends=('gtk3' 'openssl' 'alsa-lib')
+makedepends=('rustup' 'cargo' 'git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/jpochyla/psst.git')
@@ -22,7 +22,7 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
-
+ export RUSTUP_TOOLCHAIN=stable
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
# Add missing entries to desktop file