summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgarionion2021-08-18 14:00:39 +0200
committergarionion2021-08-18 14:00:39 +0200
commit6980706d7d4649cfe352bdd92220fe9813ebd4ae (patch)
tree291591245a4fc53d958972b10416cb0c3b28a081 /PKGBUILD
parentd66a9dcdf6a89ea6a1a4453b4d3aaead09133d57 (diff)
downloadaur-6980706d7d4649cfe352bdd92220fe9813ebd4ae.tar.gz
follow rust package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc059c18f3a9..2b741c76b7dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=psst-git
_pkgname="psst"
-pkgver=r213.4ee0b48
-pkgrel=1
+pkgver=r264.1d5cf32
+pkgrel=2
pkgdesc="Fast and multi-platform Spotify client with native GUI"
arch=("x86_64")
url="https://github.com/jpochyla/psst"
@@ -30,16 +30,20 @@ pkgver() {
prepare() {
cd "$_pkgname"
git submodule update --recursive --init
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
cd "$_pkgname"
- cargo build --release
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
check() {
cd "$_pkgname"
- cargo test --release
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package() {