summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgarionion2021-01-04 18:16:30 +0100
committergarionion2021-01-08 15:57:06 +0100
commit6b45d9b7c348931706b046d7e435eeedd7051043 (patch)
tree7d58c47c046efbf31e63c0dd69efbdee2c5b394e /PKGBUILD
downloadaur-6b45d9b7c348931706b046d7e435eeedd7051043.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68afcf6549df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: garionion <garionion@entr0py.de>
+
+pkgname=psst-git
+_pkgname="psst"
+pkgver=0
+pkgrel=1
+pkgdesc="Fast and multi-platform Spotify client with native GUI"
+arch=("x86_64")
+url="https://github.com/jpochyla/psst"
+license=('MIT')
+makedepends=( 'rust'
+ 'git')
+provides=("psst")
+conflicts=("psst")
+source=("git+https://github.com/jpochyla/psst.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+ git submodule update --recursive --init
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+check() {
+ cd "$_pkgname"
+ cargo test --release --locked --target-dir=target
+}
+
+package() {
+ # install
+ install -Dm 755 ${_pkgname}/target/release/psst-gui -t "${pkgdir}/usr/bin/"
+
+ # desktop entry
+
+ install -dm 755 "${pkgdir}/usr/share/applications"
+ cat > ${pkgdir}/usr/share/applications/${_pkgname}.desktop << EOF
+[Desktop Entry]
+Type=Application
+Version=${pkgver}
+Name=Psst
+Comment=Fast and multi-platform Spotify client with native GUI
+Exec=psst-gui
+Icon=psst-gui
+Terminal=false
+EOF
+
+}