summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2015-07-06 21:00:59 -0400
committerChris Severance2015-07-06 21:00:59 -0400
commit10bebc6b3c582b910505b7e57ef95efeb90a1f84 (patch)
tree040a8acf9128a4a7c74d62c1ef6a4c3231966067 /PKGBUILD
downloadaur-pstext.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..291050f13baf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
+# Category: system
+
+# Recommended build command: makepkg -scCfi
+
+# https://groups.google.com/d/msg/comp.lang.postscript/Xne2G4pxbpM/c1btCIhZc2IJ
+
+pkgname='pstext'
+pkgver='1.1'
+pkgrel='1'
+pkgdesc='Convert text to postscript (Dan Judd 1989)'
+arch=('i686' 'x86_64')
+url='http://computer-programming-forum.com/36-postscript/f38cab32dcba8136.htm'
+#license=('')
+#depends=
+#makedepends=
+#optdepends=
+source=("${pkgname}-${pkgver}.tar.gz")
+sha256sums=('a804475998ea7874a7a53c955855080f27db47451f25d54417320c96054ce2a0')
+install="${pkgname}.install"
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm644 "${pkgname}.1" "${pkgdir}/usr/share/man/man1/${pkgname}.1"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+}