summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpiotr2019-11-29 01:23:46 +0100
committerpiotr2019-11-29 01:23:46 +0100
commitd60e33e3e98389e01accf82aba923a4f3eb6e83c (patch)
tree5e513e3528510a9ad7f9b494550fe43767816b85 /PKGBUILD
parent68b3b9aade901b89d6a20d4454190199692daf1d (diff)
downloadaur-d60e33e3e98389e01accf82aba923a4f3eb6e83c.tar.gz
Packaging altered in preparation to update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 6 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e115229f660c..c09037017341 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,20 @@
# Maintainer: Piotr Miller <nwg.piotr@gmail.com>
pkgname=('psuinfo')
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc="A psutil-based command to display customizable system info, intended for Tint2 or other panels"
arch=('x86_64')
url="https://github.com/nwg-piotr/psuinfo"
license=('GPL3')
depends=('python' 'python-psutil')
-source=("https://github.com/nwg-piotr/psuinfo/raw/master/psuinfo-1.0-2"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/cpu.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/fan.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/hdd.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/mem.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/swap.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/temp.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/up.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/xfer.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/xfer-b.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/xfer-d.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/icons/xfer-u.svg"
- "https://github.com/nwg-piotr/psuinfo/raw/master/configs/psuinfo-bottom-icons.tint2rc"
- "https://github.com/nwg-piotr/psuinfo/raw/master/configs/psuinfo-bottom-text-single.tint2rc"
- "https://github.com/nwg-piotr/psuinfo/raw/master/configs/psuinfo-bottom-text.tint2rc")
+source=("https://github.com/nwg-piotr/psuinfo/archive/v$pkgver.tar.gz")
-md5sums=('7f0dff0a87d23238bcca2d64ccaa55ec'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+md5sums=('a01f5c25f16c1cac30bc75fc446cd672')
package() {
- install -D -m 755 psuinfo-1.0-2 \
- "$pkgdir"/usr/bin/psuinfo
- install -D -t "$pkgdir/usr/share/$pkgname" *.svg
- install -D -t "$pkgdir/usr/share/tint2" *.tint2rc
+ install -D -m 755 "$pkgname"-"$pkgver"/psuinfo-1.0-2 "$pkgdir"/usr/bin/psuinfo
+ install -D -t "$pkgdir"/usr/share/"$pkgname" "$pkgname"-"$pkgver"/icons/*.svg
+ install -D -t "$pkgdir/usr/share/tint2" "$pkgname"-"$pkgver"/configs/*.tint2rc
}